Eclipse platforms supported by JViews

Article ID: 2300
Last updated: 30 May, 2018
Article ID: 2300
Last updated: 30 May, 2018
Revision: 3
Views: 655
Posted: 11 Mar, 2011
by Dean J.
Updated: 30 May, 2018
by Gargani A.

Question

Does JViews support the Eclipse platform?

Answer

Since Eclipse 3.0 for embedding Swing/AWT widgets inside SWT widgets is supported on Windows with JDK 1.4 and above and on GTK and Motif with JDK 1.5, JViews 8.7 leverages the bridge between SWT and AWT.

JViews 8.7 or later provides a number of samples built for Eclipse 3.X. The Eclipse samples are distributed as Eclipse features and plugins. Please see the JViews documentation for more information. The samples provide editors for the Designer project files that integrate with the Eclipse standard views such as Property View and Outline view.

Compatibility matrix:

JViews 8.7 Eclipse 3.3, 3.4, and 3.5
JViews 8.8 Eclipse 3.3, 3.4, 3.5, 3.6, and 3.7
This article was:   Helpful | Not helpful
Report an issue
Article ID: 2300
Last updated: 30 May, 2018
Revision: 3
Views: 655
Posted: 11 Mar, 2011 by Dean J.
Updated: 30 May, 2018 by Gargani A.
Also listed in


Others in this category