Can I use DBTools.h++ 3.1.0 with MSVC 5.0?

Article ID: 1017
Last updated: 29 Jan, 2008
Article ID: 1017
Last updated: 29 Jan, 2008
Revision: 1
Views: 2873
Posted: 22 Dec, 1998
by --
Updated: 29 Jan, 2008
by
Problem


DBTools.h++ version 3.1 has been certified with Microsoft's Visual C++ 6.0 compiler, but I need to keep using the 5.0 compiler. Will DBTools.h++ still work with the older compiler?


Cause





Action


DBTools.h++ 3.1.0 has been tested for use against VC 6.0, and we recommend using this version of the Microsoft compiler with that release of DBTools.h++. However, VC 5.0 can be used with this release of DBTools.h++.

 

Please Note: this combination has not been run through our complete test suite, hence it is unsupported, but it has been successfully built and used.

 

The steps to build DBTools.h++ 3.1 against VC 5.0* are as follows:

With Edition 7 of the SPM (version 1.4.0):

 

  1. Start with a clean installation of the Software Parts Manager. Pre-existing installations of older versions of DBTools.h++ will result in header file conflicts in the build process.
  2. Build Tools.h++ version 7.0.8 with the build type you wish to use with DBTools.h++. Tools.h++ 7.0.9, which ships with edition 8 of the Software Parts Manager, is designed to work with VC 6.0, and will not build on VC 5.0.
  3. Download DBTools.h++ 3.1, and install it into this SPM installation. This can be downloaded from http://www.roguewave.com/service. If you have questions or need assistance with this step, contact your customer service representative (find out who at: http://www.roguewave.com/cgi-bin/repform.cgi).
  4. Once installed, the Build screen should display DBTools.h++ 3.1 as one of the libraries available to build. Select the build options consistent with what was just chosen with Tools.h++, and click OK.
  5. Warnings will be displayed that a dependency on Tools.h++ 7.0.9 can not be met; since you will be using Tools.h++ 7.0.8, click Continue and Yes for the following warnings.
  6. Repeat steps 3, 4, 5 and 6 for the appropriate access libraries.

    Please Note: If you are using DBTools.h++ 3.1.0, you must use an Access Library with the same version number.

 

With Edition 8 of the SPM (version 1.4.1):

 

  1. As above, but use edition 8 of the SPM, and install Tools.h++ 7.0.8 instead of DBTools.h++ (which will already be present). See your customer service representative to get the download version of Tools.h+++ 7.0.8.

 

 


*Please be sure Service Pack 3 is installed with the VC 5.0 compiler.

 



This article was:   Helpful | Not helpful
Report an issue
Article ID: 1017
Last updated: 29 Jan, 2008
Revision: 1
Views: 2873
Posted: 22 Dec, 1998 by --
Updated: 29 Jan, 2008 by

Others in this category